CVE-2017-15708
CVE.org · Publicado
- Status do registro
- Publicado
- Ano do identificador (não é o ano de publicação)
- 2017
- Publicação na fonte
- Atualização na fonte
- Importado pelo cveboard
- Snapshot da fonte
- cve_2026-10-24_midnight_baseline ·
Texto da CNA em inglês
In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI). So Apache Synapse 3.0.1 or all previous releases (3.0.0, 2.1.0, 2.0.0, 1.2, 1.1.2, 1.1.1) allows remote code execution attacks that can be performed by injecting specially crafted serialized objects. And the presence of Apache Commons Collections 3.2.1 (commons-collections-3.2.1.jar) or previous versions in Synapse distribution makes this exploitable. To mitigate the issue, we need to limit RMI access to trusted users only. Further upgrading to 3.0.1 version will eliminate the risk of having said Commons Collection version. In Synapse 3.0.1, Commons Collection has been updated to 3.2.2 version.
Fatos de produtos e versões por escopo
Dados de correção desconhecidos; nenhuma versão corrigida é deduzida aqui. Dados ausentes não comprovam ausência de correção.
Exploração desconhecida; este catálogo não avalia exploração.
Apache Synapse
- Fornecedor
- Apache Software Foundation
- Produto
- Apache Synapse
- Plataformas
- Desconhecido
- Status padrão
Desconhecido
| Versão (version) | Status (status) | Esquema de versões (versionType) | Fim exclusivo (lessThan) | Fim inclusivo (lessThanOrEqual) | Mudanças de status (at → status) |
|---|---|---|---|---|---|
| 3.0.0 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |
| 2.1.0 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |
| 2.0.0 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |
| 1.2 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |
| 1.1.2 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |
| 1.1.1 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |