cveboard RSS feed

CVE-2020-4046

CVE.org · Published

Historical CVEsJSONAI instructions

Record status
Published
Identifier year (not publication year)
2020
Source publication
Source updated
Imported by cveboard
Source snapshot
cve_2026-10-24_midnight_baseline ·

Plain text

CNA source text (English)

Authenticated XSS through embed block in WordPress

In affected versions of WordPress, users with low privileges (like contributors and authors) can use the embed block in a certain way to inject unfiltered HTML in the block editor. When affected posts are viewed by a higher privileged user, this could lead to script execution in the editor/wp-admin. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).

Scoped product and version facts

Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.

Exploitation unknown; this catalogue does not assess exploitation.

wordpress-develop

Vendor
WordPress
Product
wordpress-develop
Platforms
Unknown
Default status
Unknown
wordpress-develop · Scoped product and version facts
Version (version)Status (status)Version scheme (versionType)Exclusive end (lessThan)Inclusive end (lessThanOrEqual)Status changes (at → status)
>= 5.4.0, < 5.4.2affectedUnavailableUnavailableUnavailableNone listed
>= 5.3.0, < 5.3.4affectedUnavailableUnavailableUnavailableNone listed
>= 5.2.0, < 5.2.7affectedUnavailableUnavailableUnavailableNone listed
>= 5.1.0, < 5.1.6affectedUnavailableUnavailableUnavailableNone listed
>= 5.0.0, < 5.0.10affectedUnavailableUnavailableUnavailableNone listed
>= 4.9.0, < 4.9.15affectedUnavailableUnavailableUnavailableNone listed
>= 4.8.0, < 4.8.14affectedUnavailableUnavailableUnavailableNone listed
>= 4.7.0, < 4.7.18affectedUnavailableUnavailableUnavailableNone listed
>= 4.6.0, < 4.6.19affectedUnavailableUnavailableUnavailableNone listed
>= 4.5.0, < 4.5.22affectedUnavailableUnavailableUnavailableNone listed
>= 4.4.0, < 4.4.23affectedUnavailableUnavailableUnavailableNone listed
>= 4.3.0, < 4.3.24affectedUnavailableUnavailableUnavailableNone listed
>= 4.2.0, < 4.2.28affectedUnavailableUnavailableUnavailableNone listed
>= 4.1.0, < 4.1.31affectedUnavailableUnavailableUnavailableNone listed
>= 4.0.0, < 4.0.31affectedUnavailableUnavailableUnavailableNone listed
>= 3.9.0, < 3.9.32affectedUnavailableUnavailableUnavailableNone listed
>= 3.8.0, < 3.8.34affectedUnavailableUnavailableUnavailableNone listed
>= 3.7.0, < 3.7.34affectedUnavailableUnavailableUnavailableNone listed