CVE-2021-39222
CVE.org · Published
- Record status
- Published
- Identifier year (not publication year)
- 2021
- Source publication
- Source updated
- Imported by cveboard
- Source snapshot
- cve_2026-10-24_midnight_baseline ·
CNA source text (English)
XSS in Talk
Nextcloud is an open-source, self-hosted productivity platform. The Nextcloud Talk application was vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. For exploitation, a user would need to right-click on a malicious file and open the file in a new tab. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Talk application is upgraded to patched versions 10.0.7, 10.1.4, 11.1.2, 11.2.0 or 12.0.0. As a workaround, use a browser that has support for Content-Security-Policy.
Scoped product and version facts
Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.
Exploitation unknown; this catalogue does not assess exploitation.
security-advisories
- Vendor
- nextcloud
- Product
- security-advisories
- Platforms
- Unknown
- Default status
Unknown
| Version (version) | Status (status) | Version scheme (versionType) | Exclusive end (lessThan) | Inclusive end (lessThanOrEqual) | Status changes (at → status) |
|---|---|---|---|---|---|
| < 10.0.7 | affected | Unavailable | Unavailable | Unavailable | None listed |
| >= 10.1.0, < 10.1.4 | affected | Unavailable | Unavailable | Unavailable | None listed |
| >= 11.1.0, < 11.1.2 | affected | Unavailable | Unavailable | Unavailable | None listed |
| < 11.2.0 | affected | Unavailable | Unavailable | Unavailable | None listed |
| >= 12.0.0.alpha-1, < 12.0.0 | affected | Unavailable | Unavailable | Unavailable | None listed |