CVE-2021-39222
CVE.org · Publicado
- Status do registro
- Publicado
- Ano do identificador (não é o ano de publicação)
- 2021
- Publicação na fonte
- Atualização na fonte
- Importado pelo cveboard
- Snapshot da fonte
- cve_2026-10-24_midnight_baseline ·
Texto da CNA em inglês
XSS in Talk
Nextcloud is an open-source, self-hosted productivity platform. The Nextcloud Talk application was vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. For exploitation, a user would need to right-click on a malicious file and open the file in a new tab. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Talk application is upgraded to patched versions 10.0.7, 10.1.4, 11.1.2, 11.2.0 or 12.0.0. As a workaround, use a browser that has support for Content-Security-Policy.
Fatos de produtos e versões por escopo
Dados de correção desconhecidos; nenhuma versão corrigida é deduzida aqui. Dados ausentes não comprovam ausência de correção.
Exploração desconhecida; este catálogo não avalia exploração.
security-advisories
- Fornecedor
- nextcloud
- Produto
- security-advisories
- Plataformas
- Desconhecido
- Status padrão
Desconhecido
| Versão (version) | Status (status) | Esquema de versões (versionType) | Fim exclusivo (lessThan) | Fim inclusivo (lessThanOrEqual) | Mudanças de status (at → status) |
|---|---|---|---|---|---|
| < 10.0.7 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |
| >= 10.1.0, < 10.1.4 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |
| >= 11.1.0, < 11.1.2 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |
| < 11.2.0 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |
| >= 12.0.0.alpha-1, < 12.0.0 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |