CVE-2021-4231
CVE.org · Published
- Record status
- Published
- Identifier year (not publication year)
- 2021
- Source publication
- Source updated
- Imported by cveboard
- Source snapshot
- cve_2026-10-24_midnight_baseline ·
CNA source text (English)
Angular Comment cross site scripting
A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 11.0.5 and 11.1.0-next.3 is able to address this issue. The name of the patch is ba8da742e3b243e8f43d4c63aa842b44e14f2b09. It is recommended to upgrade the affected component.
Scoped product and version facts
Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.
Exploitation unknown; this catalogue does not assess exploitation.
Angular
- Vendor
- unspecified
- Product
- Angular
- Platforms
- Unknown
- Default status
Unknown
| Version (version) | Status (status) | Version scheme (versionType) | Exclusive end (lessThan) | Inclusive end (lessThanOrEqual) | Status changes (at → status) |
|---|---|---|---|---|---|
| 11.0.0 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 11.0.1 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 11.0.2 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 11.0.3 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 11.0.4 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 11.1.0-next.0 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 11.1.0-next.1 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 11.1.0-next.2 | affected | Unavailable | Unavailable | Unavailable | None listed |