cveboard RSS feed

CVE-2022-39260

CVE.org · Published

Historical CVEsJSONAI instructions

Record status
Published
Identifier year (not publication year)
2022
Source publication
Source updated
Imported by cveboard
Source snapshot
cve_2026-10-24_midnight_baseline ·

Plain text

CNA source text (English)

Git vulnerable to Remote Code Execution via Heap overflow in `git shell`

Git is an open source, scalable, distributed revision control system. `git shell` is a restricted login shell that can be used to implement Git's push/pull functionality via SSH. In versions prior to 2.30.6, 2.31.5, 2.32.4, 2.33.5, 2.34.5, 2.35.5, 2.36.3, and 2.37.4, the function that splits the command arguments into an array improperly uses an `int` to represent the number of entries in the array, allowing a malicious actor to intentionally overflow the return value, leading to arbitrary heap writes. Because the resulting array is then passed to `execv()`, it is possible to leverage this attack to gain remote code execution on a victim machine. Note that a victim must first allow access to `git shell` as a login shell in order to be vulnerable to this attack. This problem is patched in versions 2.30.6, 2.31.5, 2.32.4, 2.33.5, 2.34.5, 2.35.5, 2.36.3, and 2.37.4 and users are advised to upgrade to the latest version. Disabling `git shell` access via remote logins is a viable short-term workaround.

Scoped product and version facts

Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.

Exploitation unknown; this catalogue does not assess exploitation.

git

Vendor
git
Product
git
Platforms
Unknown
Default status
Unknown
git · Scoped product and version facts
Version (version)Status (status)Version scheme (versionType)Exclusive end (lessThan)Inclusive end (lessThanOrEqual)Status changes (at → status)
< 2.30.6affectedUnavailableUnavailableUnavailableNone listed
> 2.31.0, < 2.31.5affectedUnavailableUnavailableUnavailableNone listed
> 2.32.0, < 2.32.4affectedUnavailableUnavailableUnavailableNone listed
> 2.33.0, < 2.33.5affectedUnavailableUnavailableUnavailableNone listed
> 2.34.0, < 2.34.5affectedUnavailableUnavailableUnavailableNone listed
> 2.34.0, < 2.35.5affectedUnavailableUnavailableUnavailableNone listed
> 2.35.0, < 2.36.3affectedUnavailableUnavailableUnavailableNone listed
> 2.37.0, < 2.37.4affectedUnavailableUnavailableUnavailableNone listed