CVE-2022-39260
CVE.org · Publicado
- Status do registro
- Publicado
- Ano do identificador (não é o ano de publicação)
- 2022
- Publicação na fonte
- Atualização na fonte
- Importado pelo cveboard
- Snapshot da fonte
- cve_2026-10-24_midnight_baseline ·
Texto da CNA em inglês
Git vulnerable to Remote Code Execution via Heap overflow in `git shell`
Git is an open source, scalable, distributed revision control system. `git shell` is a restricted login shell that can be used to implement Git's push/pull functionality via SSH. In versions prior to 2.30.6, 2.31.5, 2.32.4, 2.33.5, 2.34.5, 2.35.5, 2.36.3, and 2.37.4, the function that splits the command arguments into an array improperly uses an `int` to represent the number of entries in the array, allowing a malicious actor to intentionally overflow the return value, leading to arbitrary heap writes. Because the resulting array is then passed to `execv()`, it is possible to leverage this attack to gain remote code execution on a victim machine. Note that a victim must first allow access to `git shell` as a login shell in order to be vulnerable to this attack. This problem is patched in versions 2.30.6, 2.31.5, 2.32.4, 2.33.5, 2.34.5, 2.35.5, 2.36.3, and 2.37.4 and users are advised to upgrade to the latest version. Disabling `git shell` access via remote logins is a viable short-term workaround.
Fatos de produtos e versões por escopo
Dados de correção desconhecidos; nenhuma versão corrigida é deduzida aqui. Dados ausentes não comprovam ausência de correção.
Exploração desconhecida; este catálogo não avalia exploração.
git
- Fornecedor
- git
- Produto
- git
- Plataformas
- Desconhecido
- Status padrão
Desconhecido
| Versão (version) | Status (status) | Esquema de versões (versionType) | Fim exclusivo (lessThan) | Fim inclusivo (lessThanOrEqual) | Mudanças de status (at → status) |
|---|---|---|---|---|---|
| < 2.30.6 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |
| > 2.31.0, < 2.31.5 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |
| > 2.32.0, < 2.32.4 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |
| > 2.33.0, < 2.33.5 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |
| > 2.34.0, < 2.34.5 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |
| > 2.34.0, < 2.35.5 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |
| > 2.35.0, < 2.36.3 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |
| > 2.37.0, < 2.37.4 | affected | Indisponível | Indisponível | Indisponível | Nenhuma listada |