cveboard RSS feed

CVE-2025-46701

CVE.org · Published

Historical CVEsJSONAI instructions

Record status
Published
Identifier year (not publication year)
2025
Source publication
Source updated
Imported by cveboard
Source snapshot
cve_2026-10-24_midnight_baseline ·

Plain text

CNA source text (English)

Apache Tomcat: Security constraint bypass for CGI scripts

Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.

Scoped product and version facts

Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.

Exploitation unknown; this catalogue does not assess exploitation.

Apache Tomcat

Vendor
Apache Software Foundation
Product
Apache Tomcat
Platforms
Unknown
Default status
unaffected
Apache Tomcat · Scoped product and version facts
Version (version)Status (status)Version scheme (versionType)Exclusive end (lessThan)Inclusive end (lessThanOrEqual)Status changes (at → status)
11.0.0-M1affectedsemverUnavailable11.0.6None listed
10.1.0-M1affectedsemverUnavailable10.1.40None listed
9.0.0.M1affectedsemverUnavailable9.0.104None listed
8.5.0affectedsemverUnavailable8.5.100None listed
3unknownsemver8.5.0UnavailableNone listed
10.0.0-M1unknownsemverUnavailable10.0.27None listed