cveboard RSS feed

CVE-2025-48385

CVE.org · Published

Historical CVEsJSONAI instructions

Record status
Published
Identifier year (not publication year)
2025
Source publication
Source updated
Imported by cveboard
Source snapshot
cve_2026-10-24_midnight_baseline ·

Plain text

CNA source text (English)

Git alllows arbitrary file writes via bundle-uri parameter injection

Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. When cloning a repository Git knows to optionally fetch a bundle advertised by the remote server, which allows the server-side to offload parts of the clone to a CDN. The Git client does not perform sufficient validation of the advertised bundles, which allows the remote side to perform protocol injection. This protocol injection can cause the client to write the fetched bundle to a location controlled by the adversary. The fetched content is fully controlled by the server, which can in the worst case lead to arbitrary code execution. The use of bundle URIs is not enabled by default and can be controlled by the bundle.heuristic config option. Some cases of the vulnerability require that the adversary is in control of where a repository will be cloned to. This either requires social engineering or a recursive clone with submodules. These cases can thus be avoided by disabling recursive clones. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.

Scoped product and version facts

Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.

Exploitation unknown; this catalogue does not assess exploitation.

git

Vendor
git
Product
git
Platforms
Unknown
Default status
Unknown
git · Scoped product and version facts
Version (version)Status (status)Version scheme (versionType)Exclusive end (lessThan)Inclusive end (lessThanOrEqual)Status changes (at → status)
< 2.43.7affectedUnavailableUnavailableUnavailableNone listed
>= 2.44.0-rc0, < 2.44.4affectedUnavailableUnavailableUnavailableNone listed
>= 2.45.0-rc0, < 2.45.4affectedUnavailableUnavailableUnavailableNone listed
>= 2.46.0-rc0, < 2.46.4affectedUnavailableUnavailableUnavailableNone listed
>= 2.47.0-rc0, < 2.47.3affectedUnavailableUnavailableUnavailableNone listed
>= 2.48.0-rc0, < 2.48.2affectedUnavailableUnavailableUnavailableNone listed
>= 2.49.0-rc0, < 2.49.1affectedUnavailableUnavailableUnavailableNone listed
>= 2.50.0-rc0, < 2.50.1affectedUnavailableUnavailableUnavailableNone listed