CVE-2025-53689
CVE.org · Published
- Record status
- Published
- Identifier year (not publication year)
- 2025
- Source publication
- Source updated
- Imported by cveboard
- Source snapshot
- cve_2026-10-24_midnight_baseline ·
CNA source text (English)
Apache Jackrabbit: XXE vulnerability in jackrabbit-spi-commons
Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges. Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.
Scoped product and version facts
Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.
Exploitation unknown; this catalogue does not assess exploitation.
Apache Jackrabbit
- Vendor
- Apache Software Foundation
- Product
- Apache Jackrabbit
- Platforms
- Unknown
- Default status
unaffected- Package
- org.apache.jackrabbit:jackrabbit-spi-commons
| Version (version) | Status (status) | Version scheme (versionType) | Exclusive end (lessThan) | Inclusive end (lessThanOrEqual) | Status changes (at → status) |
|---|---|---|---|---|---|
| 2.20.0 | affected | maven | 2.20.17 | Unavailable | None listed |
| 2.22.0 | affected | maven | 2.22.1 | Unavailable | None listed |
| 2.23.0-beta | affected | maven | 2.23.2-beta | Unavailable | None listed |