CVE-2026-29146
CVE.org · Published
- Record status
- Published
- Identifier year (not publication year)
- 2026
- Source publication
- Source updated
- Imported by cveboard
- Source snapshot
- cve_2026-10-24_midnight_baseline ·
CNA source text (English)
Apache Tomcat: EncryptInterceptor vulnerable to padding oracle attack by default
Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.
Scoped product and version facts
Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.
Exploitation unknown; this catalogue does not assess exploitation.
Apache Tomcat
- Vendor
- Apache Software Foundation
- Product
- Apache Tomcat
- Platforms
- Unknown
- Default status
unaffected
| Version (version) | Status (status) | Version scheme (versionType) | Exclusive end (lessThan) | Inclusive end (lessThanOrEqual) | Status changes (at → status) |
|---|---|---|---|---|---|
| 11.0.0-M1 | affected | semver | Unavailable | 11.0.18 | None listed |
| 10.0.0-M1 | affected | semver | Unavailable | 10.1.52 | None listed |
| 9.0.13 | affected | semver | Unavailable | 9.0.115 | None listed |
| 8.5.38 | affected | semver | Unavailable | 8.5.100 | None listed |
| 7.0.100 | affected | semver | Unavailable | 7.0.109 | None listed |