CVE-2021-38153
CVE.org · Published
- Record status
- Published
- Identifier year (not publication year)
- 2021
- Source publication
- Source updated
- Imported by cveboard
- Source snapshot
- cve_2026-10-24_midnight_baseline ·
CNA source text (English)
Timing Attack Vulnerability for Apache Kafka Connect and Clients
Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.
Scoped product and version facts
Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.
Exploitation unknown; this catalogue does not assess exploitation.
Apache Kafka
- Vendor
- Apache Software Foundation
- Product
- Apache Kafka
- Platforms
- Unknown
- Default status
Unknown
| Version (version) | Status (status) | Version scheme (versionType) | Exclusive end (lessThan) | Inclusive end (lessThanOrEqual) | Status changes (at → status) |
|---|---|---|---|---|---|
| Apache Kafka 2.0.x | affected | custom | Unavailable | 2.0.1 | None listed |
| Apache Kafka 2.1.x | affected | custom | Unavailable | 2.1.1 | None listed |
| Apache Kafka 2.2.x | affected | custom | Unavailable | 2.2.2 | None listed |
| Apache Kafka 2.3.x | affected | custom | Unavailable | 2.3.1 | None listed |
| Apache Kafka 2.4.x | affected | custom | Unavailable | 2.4.1 | None listed |
| Apache Kafka 2.5.x | affected | custom | Unavailable | 2.5.1 | None listed |
| Apache Kafka 2.6.x | affected | custom | Unavailable | 2.6.2 | None listed |
| Apache Kafka 2.7.x | affected | custom | Unavailable | 2.7.1 | None listed |
| Apache Kafka 2.8.x | affected | custom | Unavailable | 2.8.0 | None listed |