cveboard Feed RSS

CVE-2021-38153

CVE.org · Publicado

Histórico de CVEsJSONInstruções para IA

Status do registro
Publicado
Ano do identificador (não é o ano de publicação)
2021
Publicação na fonte
Atualização na fonte
Importado pelo cveboard
Snapshot da fonte
cve_2026-10-24_midnight_baseline ·

Texto simples

Texto da CNA em inglês

Timing Attack Vulnerability for Apache Kafka Connect and Clients

Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.

Fatos de produtos e versões por escopo

Dados de correção desconhecidos; nenhuma versão corrigida é deduzida aqui. Dados ausentes não comprovam ausência de correção.

Exploração desconhecida; este catálogo não avalia exploração.

Apache Kafka

Fornecedor
Apache Software Foundation
Produto
Apache Kafka
Plataformas
Desconhecido
Status padrão
Desconhecido
Apache Kafka · Fatos de produtos e versões por escopo
Versão (version)Status (status)Esquema de versões (versionType)Fim exclusivo (lessThan)Fim inclusivo (lessThanOrEqual)Mudanças de status (at → status)
Apache Kafka 2.0.xaffectedcustomIndisponível2.0.1Nenhuma listada
Apache Kafka 2.1.xaffectedcustomIndisponível2.1.1Nenhuma listada
Apache Kafka 2.2.xaffectedcustomIndisponível2.2.2Nenhuma listada
Apache Kafka 2.3.xaffectedcustomIndisponível2.3.1Nenhuma listada
Apache Kafka 2.4.xaffectedcustomIndisponível2.4.1Nenhuma listada
Apache Kafka 2.5.xaffectedcustomIndisponível2.5.1Nenhuma listada
Apache Kafka 2.6.xaffectedcustomIndisponível2.6.2Nenhuma listada
Apache Kafka 2.7.xaffectedcustomIndisponível2.7.1Nenhuma listada
Apache Kafka 2.8.xaffectedcustomIndisponível2.8.0Nenhuma listada