CVE-2026-11440
CVE.org · Published
- Record status
- Published
- Identifier year (not publication year)
- 2026
- Source publication
- Source updated
- Imported by cveboard
- Source snapshot
- cve_2026-10-24_midnight_baseline ·
CNA source text (English)
theonedev REST API default-branch improper authorization
A vulnerability was determined in theonedev onedev up to 15.0.5. This affects an unknown part of the file /repositories/{projectId}/default-branch of the component REST API. This manipulation of the argument project.defaultBranch causes improper authorization. It is possible to initiate the attack remotely. Upgrading to version 15.0.6 is able to mitigate this issue. Upgrading the affected component is advised.
Scoped product and version facts
Fix information unknown; no fixed version is derived here. Missing information does not prove that no fix exists.
Exploitation unknown; this catalogue does not assess exploitation.
onedev
- Vendor
- theonedev
- Product
- onedev
- Platforms
- Unknown
- Default status
Unknown
| Version (version) | Status (status) | Version scheme (versionType) | Exclusive end (lessThan) | Inclusive end (lessThanOrEqual) | Status changes (at → status) |
|---|---|---|---|---|---|
| 15.0.0 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 15.0.1 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 15.0.2 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 15.0.3 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 15.0.4 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 15.0.5 | affected | Unavailable | Unavailable | Unavailable | None listed |
| 15.0.6 | unaffected | Unavailable | Unavailable | Unavailable | None listed |